The Games > Quest for Infamy

v1.1 Changelog

(1/3) > >>

Here is the full List of Changes for v1.1 - Spoilers Inside, so read at own risk!

A list of the changes made to the game for the 1.1 Release.
Spoiler (hover to show)General Changes

* Fixed a number of typos and text / voice mismatches
* Treants Error - This has now been repaired so the Treants will not be on fire if you've previously done the Raven quest.
* Treant Pinecone Error - if you give the Pinecone to  Right Treant, now works properly
* Fixed the crash that could occasionally occur at the Hall of Laws in Tyr - Looking for a character not there
* Corrected the issue where you couldn't get a venom sack from a snake.
* Fixed possible error when clicking look icon on the fountain in the background of the Volksville Marketplace Screen
* Fixed an error that caused the game to "hang" if you lit the cigar with the flint in your inventory. Now shows the correct animation.
* No longer able to use the map while in the bottom of the well.
* Using Attack icon on Skeleton enemy may have caused a game crash - this has now been fixed.
* Fixed the Archery GUI staying on if you transition to night on day 2
* Fixed an issue where it was possible to crash the game when trying to escape combat at the exact moment you died.
* F6 now activates infamy score & resets and displays the last banner achieved.
* Able to Use Fishing Net on Fishing Pole
* Able to cast cloud to get down to beach in South Woods
* Fixed a situation where it was possible to break into the moonshiners hut and get the payment after the moonshiner had already paid you.
* Fixed the achievement "Shake, Rattle and Roll" from appearing if you break down the door of the moonshiners hut. Just taking his purse from his cabin isn't achievement worthy!
* Fixed error where you were able to level climbing over 100 on the slavers balcony
* Fixed the outdoor latrine so you need to use your lockpick on the door as a Rogue, instead of just your hand.
* Fixed achievement "A Paladin Loves You" not occuring if you cast the unlock spell on the prisoners in the dungeon.
* 5 Second Sneak Timer Added to Rayford's House, Brattle's Cabin, Mayor's House (at night), Volksville House 1, Volksville House 2 and the Bank. No level is required, just to be sneaking.
* Fixed an issue where it was possible to walk into bank without picking the lock if you rest near the bank till dusk or night
* Fixed an issue where Roehm would say "Is everyone in this valley an asshole?" if the player hadn't had tea with the Mayor when they completed the Raven quest.
* Changed the way the lockpicking works on the door near the Blacksmith - if you attempt to pick the lock while the smith is watching, he'll call Rayford.
* Fixed error where Roehm buys the "last" Cigar, but it's not the last one!
* Changed the death message if you get killed by the caravan guards, the old one gave a major plot spoiler!
* Allow the player to use the climbers kit to get onto the slavers balcony
* Added interaction messages to the Brigand Ambush Caravan and Guard on Horse
* Added in the ability to climb the town wall in all visible town wall screens (except the entrance as you can already climb the gate.)
* The Min/Max Achievement no longer includes Mystical Power, Stealth and Thievery. This is so all classes are able to get the achievement.
* Fixed a bug that caused the game to go all screwy if the time of day changed while in the archery screen
* Fixed game crash/freeze when tiger wakes on mayors patio
* It looks like attacking the moonshiner after roughing him up should be fixed now.
* fixed issue with inventory scrolling not working with mouse.
* Fixed an infinite loop occuring upon drinking from the river crossing in the Volksville Woods
* No longer able to pickpocket the drunk thief more than once
* Apple Farmer no longer around in Act 3
* Replaced Nighttime Swamp Combat Background as it was cutting off in the wrong place
* Fixed Hummel's Animation getting gem from Crpyt
* Removed reference to "25 Gold" from Rynn
* Fixed being able to burn the treants more than once with the flame spell
* Fixed being able to burn the cube more than once with the flame spell
* Fixed being able to burn down the oak tree if you've already got the owl feather
* Put in reasons why you can't get the feather from the pigeons in Tyr or from O'Burrs raven
* Fixed notifications for Hummel Infamy points and Floating over Red Bush infamy points
* Made sure you can still get the free sample of moonshine from Marlon if you do the goat turd quest first. Also gives Marlon the goat turd if you talk to him after accepting the mission and you're carrying the turd. And fixed a small bug that occured when clicking the purse on Marlon and a line of text comes up saying you can't do anything with it.
* Added in drinking the moonshine as an option for earning the coned achievement
* Fixed the owl staying onscreen all the time if you rest all night on the Oak Tree screen. He'll be gone when you leave the screen. Because of this also allowed the ability to hit the tree with your sword, cast the flame spell at the owl during the day, which also fixes the issue of being able to scare the Owl more than once.
* Fixed the situation where the game could go into an infinite loop of Roehm walking back and forth in the thieves hideout exterior
* Fixed some of the walkbehinds and walkable areas of the thieves hideout exterior
* Fixed a crash occuring if you try to flaming vengeance spell the cube more than once
* Fixed a clipping issue when walking left on the endless mine screen/s
* Fixed the ability to "accidently" get around the cube in the sewers and creating a dead-end situation
* Stopped the clock ticking over to the next time section (day/dusk/night) inside the Mayors house, this is to prevent the game locking up due to time issues
* Removed the ability to use the chain to climb the slavers balcony, it's too damn heavy
* Allowed the rogue to use his map in Tyr at night as his Tyr exit is not the front gates which are locked
* Fixed the ability to level up your magic if Voleris is on screen at the Slaver House and you continually click on the cloud spell or when you slip and fall out of the gnolls cave
* Fixed a infinite loop that could occur in the mayors house in Tyr if you trigger a region at the moment the mayor starts walking back
* Changed the parameters for getting the brains, you have to be on the necromancer quest now. It will also now award you 20 Infamy points
* Fixed the "Hocus Pocus" achievement to work regardless of the order you give Prospero the ingredients
* Fixed bug with being attacked when sleeping in the tent/without tent.
* Fixed some clipping issues in the pub with Kurdt, and removed him having two mugs for a split second when he stands up
* Removed the 10 foot of hemp rope object from the game. It was duplicating the climbers kit anyway. Anything you could previously climb with the rope can be climbed with the kit.
* Fixed a number of typos in graphics (library books etc)
* Fixed the brigand lair bush and the apocathary door staying open if you map out.
* Made sure the blacksmith is now out during dusk as well as night after the first day.
* Removed the ability to get the seal piece from the Gnoll more than once.
* Fixed an issue where Roehm was stuck on a non-walkable area if defeated in combat on day 1 that he initiated.
* Fixed an issue where you could stab the head outside town then leave the screen and come back and not be able to get the blood.
* Changed it so Prospero will give you the magic map on day 3 instead of 4 if you haven't already found it.
* Fixed the ability to free the prisoners in Rayfords dungeon twice (spell then key).
* Fixed the ability to use the magic map to enter the thieves tunnels before you've discovered the thieves guild. This also fixes an issue if you use the map to enter the theives guild you won't trigger the meeting with the chief thief because that's linked to walking in the front door.
* Fixed an issue where time went backwards if you go your first seal piece at night.
* Fixed a glitch where Roehm walks across the water at the base of the aquaduct when trying to exit the room to the south from the right side. This was never intended to be an exit.
* Fixed an issue where Roehm would transition to the chapel room by walking to the far right edge of the caretakers house room.
* Added walkbehinds for foreground objects in caretakers house room.
* If you've not seen the Morroi cutscene outside Rayfords office on Day 2 and it hits dusk you'll go there first before you go to the Gorth cutscene in the marketplace. This is to avoid the (unlikely) event someone could miss this scene as plotwise it's vital and is referenced again later in the game.
* Fixed some minor tinting issues with the Killington Fountain and the Tyr Arrow door at night / dusk
* Added ability to give cigar to Gnoll
* Roehm will walk to the wall in the well when he looks or interacts with it - just makes a bit more sense
* Death if you change OUT of your green robes in front of the Morroi
* Changed after you accept Kurdt's ambush quest so he will walk north and leave the room, getting ready for the ambush
* Added in the ability to use the grapling hook to climb the vines in the sherrif's garden
* Added in the ability to feed the tiger with the skinned rabbit (you can steal another rabbit if you aren't already carrying one).
* Fixed the music in Tyr Act 3 so the tense battle theme always plays
* If Roehm exits south on the Tyr Aquaduct Top Wall after Voleris has exited south, he'll be arrested.
* Added SFX for the Mayor falling off the lighthouse.
* Fixed an occasional freeze when playing the card game with Prospero
* Added a tutorial of sorts to Ned O'King about combat
* Fixed an error where the fortune teller won't tell you anything
* As a brigand you no longer need to solve the maze if you enter the south woods through the brigand hideout
* Fixed an issue where the main icon bar wouldn't switch back on if you tried to use the clock icon in the Inn's bedroom
* Changed the way you recieve the note from Kayanna from Kit in the pub. You now recieve it on the day AFTER you meet Kayanna (the night you're supposed to meet her outside the pub). If you don't go into the pub, Kessel will tell you the next day as well. This is to help avoid a situation where you can meet Kayanna without confronting Hummel.
* Fixed an issue where Roehm ate a ration after sleeping in the Inn instead of wanting to go downstairs and eating from Ina,
* Fixed an issue where if you had already broken into the Mayors house, then went for tea with the Mayor, the statue would stay in the break-in position and you would be able to climb it to the balcony, breaking all the character interactions up there. You can no longer climb onto the balcony except at night.
* Added in reasons why you can't just use the pint glass or helm on the dead beast.
* Fixed when Roehm jumps off the rope into the well so the water is only ankle height, same as when walking on it.
* Fixed Prospero's dialog in Act 2 so the Necromancer topic doesn't show up unless you've talked about the job he has for you.
* Added an animation for skinning Markus' head if you had not already stabbed it.
* Morroi rune puzzle has been changed slightly in that if you fail and retry, the runes will reset to their original positions instead of staying rotated. A message on the first time you attempt the puzzle also explains how to operate the puzzle.
* A new (forth!) title screen has been added.
* Fixed a graphical issue on the Little Dock in Tyr screen where the ocean didn't reach the sky at dusk and night.
* Added in animation for the fountain in the vision at the Killington manor.
* Added in animations for the final cutscene of Rayford and Roehm squaring off.

Achievement Changes

* Fixed the achievement "A Paladin Loves You" so it triggers if you use the spell.
* Fixed "Pisshead" Achievement
* Changed "Min/Max" Achievement so it triggers on weapon stats making it to 100. Previously included Mystical Power and Stealth but these can't be raised by every class.
* Fixed achievement "Sewer Rat" not triggering in Steam
* Fixed achievement "Collector of Useless Crap" not triggering in Steam
* Fixed achievement "Pitched Your Tent" not triggering
* Cleaned up the Achievement GUI - Removed a green border surrounding it, fixed graphics that were displaying invisible pixels, replaced OK button with correct one, corrected some of the achievment graphics that were displaying incorrectly
* Achievement GUI now pauses game when it's displayed
* Added button to control panel for Achievements

Moonshiner Quest Changes

* Visa is no longer random. When you accept the quest from Rayford, Visa will be placed in one of three rooms (South Woods Top 1, Top 2 or Top 3). He will stay there until you pay him.
* Roehm will autowalk to hide and ambush Randy after you've completed your task for the hunter.
* The bush is able to be hacked using the attack icon by all classes, not just the brigand.
* This is no longer possible before act 2, as originally intended.

Slaver House Changes

* Each section is now separate to avoid any clipping issues we had.
* If you're not sneaking when you enter the rooms with the guards (main room and hallway) you'll die.
* You must peak in on the rooms with guards before you enter them or you'll die.
* The slaver will stop animating when you wake him and start again after a few seconds if you don't move. This provides a visual clue for this puzzle.
* The slaver guards can be killed by sword, throwing daggers or inner fear spell.
* The treasure room has two slaves in it. You can free them and this will allow you to access their loot hidden in the wall.

Combat and Statistic Changes

* All stats should now be fixed so they level properly, fixed a bug where Weapon % Hit doesn't level properly sometimes.
* Stats (except those noted) now increase at the following rates - Below 50 every four uses. Between 50 and 80 every 8 uses. Above 80 every 12 uses.
* Mystical Power increases at the same rate as all other stats. In combat usage your spells get more powerful at 50 and 80. You'll notice a different spell animation for these. Flaming Vengeance and Icy Shards do 8 / 12 / 16 damage for the three levels of spell power. Plague spell does 2/4/6 for the three levels of spell power.
* Weapon % Use increases at the following rate. Below 50 every 5 uses. Between 50 and 80 every 10 uses. Above 80 every 15 uses.
* Stats - The stats have been fixed so they all level properly now. Combat stats will also increase on a miss as well as a hit as was originally intended. All the stats level at a faster rate than previously, although still on a sliding scale.
* Damage absorbed by armors has been reduced. Leather will absorb 1 damage, Hide will absorb 2 and Chain will absorb 3.
* Fixed stat increase issue by checking for >= instead of == .  This should fix stat increases and notifications.
* Fixed notification bar occasionally flying off to the left - never to be seen again.
* Changed the way the combat dummy in the brigand hideout works so that it's only once a day, and will give you a guaranteed increase in each of the three combat stats, plus a +2 increase in Weapon % Hit.

Shop Interface Changes

* The initial shop text now explains how to steal something in addition to the existing look and buy instructions
* Unsuccessful stealing attempts can now happen once a day per shop (reset at dawn). Example - You attempt to steal a healing potion from Jerrod but fail, you can't attempt to steal a healing potion or any of his other products that day. A message displays telling you the shopkeeper is being more careful since your failed attempt
* A successful attempt will stop you from stealing further from that particular shop
* As before, all successful and unsuccessful attempts add to your stealing
* Fixed a bug that allowed you to steal more than one item per shop
* Changed the failed attempt message to be clearer that you failed but gained some experience

New Rooms/Content

 * inside the Bridge Tower
   - (SPOILERS) Can break open rusted jail for treasure (Brigand)
* Garden of Aiia
  - Hiden garden for Sorcerer to find. (SPOILERS)
* Inside The Barracks of Tyr's Arrows
 - Be brave, and climb inside the barracks and steal from (gulp) Tyr's Arrows (rogue)

Break in Rooms

* Volksville 1
* Volksville 2
* Rayford's House
* Bank
* Mayor's House
* Mayor's Patio
* Brattle's Cabin

Export Character

* Player now types in name of file
* Saves as Roehm.dat if they type an existing filename
* If Roehm.dat exisits, it saves over Roehm.dat


--- Quote from: Blackthorne on February 06, 2015, 09:18:59 AM ---
* Allow the player to use the rope or chain to get onto the slavers balcony

* Removed the ability to use the chain to climb the slavers balcony, it's too damn heavy

--- End quote ---

 ??? ??? ??? ??? ??? ??? ??? ??? ??? ???

Really?  COME ON !!!  Which is it ?!?   >:(

It's all of those.

Heh, actually, these issues got dealt with in order and written down that way!


Is Linux release of 1.1 coming to GOG as well?


--- Quote from: shmerl on February 09, 2015, 01:31:43 PM ---Is Linux release of 1.1 coming to GOG as well?

--- End quote ---

Yep! Our guy is packaging it up and sending it off to them soon!



[0] Message Index

[#] Next page

Go to full version